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IntroDuctIon
Mechanochemistry is the area of chemistry that deals with trans-
formations induced and/or supported by mechanical force1.  
In the form of grinding and milling, mechanochemistry has 
been known in metallurgy and mineral processing since the 4th 
century B.C.2, and organic chemists have used such processes 
since at least the 19th century3. Modern mechanochemistry is a 
broad area, encompassing diverse topics such as bulk transforma-
tions by grinding, shearing and milling1, polymer cleavage by the 
mechanical stress of sonication4 and studies of molecular struc-
ture and bonding by stretching and compression of individual 
molecules5. Reactions by grinding or milling have recently been 
recognized as more versatile and cleaner, as well as faster and more 
efficient (in terms of energy, materials and solvent), alternatives 
to conventional syntheses in solution1. The current re-emergence 
of mechanochemistry is closely associated with the advance of 
‘green’ chemistry, in which mechanochemistry can provide an 
ideal solvent-free environment for a diversity of transformations6, 
including coordination polymer7 and metal-organic framework 
synthesis8, asymmetric catalysis9, metathesis10 and molecular 
self-assembly11.

Despite their popularity and a growing number of applica-
tions, mechanistic understanding of mechanochemical reactions 
has remained poor. This is largely due to a lack of methods for 
monitoring the reaction course. Although indirect monitoring 
of mechanochemical reactions is sometimes possible by measur-
ing the pressure within the milling assembly or its temperature, 
such methods are limited to reactions involving gases12 or highly 
exothermic self-igniting processes13, respectively. We recently 
presented the results of the first methodology for in situ and 
real-time observation of mechanochemical reactions using X-ray 
diffraction14. Here we describe details of this novel methodology, 
which uses high-energy, highly penetrating X-rays to monitor 

and identify crystalline reactants, intermediates and products in 
a mechanochemical reaction.

General design of mechanochemical techniques
Although mechanochemical reactions can be conducted in a 
chemical laboratory by using only a mortar and pestle, the con-
ditions for such grinding processes are difficult to define and 
include the identity of the experimenter, temperature, humidity 
and atmospheric composition. The use of a commercially avail-
able mechanical laboratory mill allows the sample to be enclosed 
within a reaction vessel. Thus, for maximum reproducibility and 
systematic studies, a mechanical mill is preferred to a mortar and 
pestle. Different laboratory milling equipment designs include 
shaker mills (also known as mixer mills), planetary mills or 
attritors15. In a shaker mill, the sample is placed within a closed 
or sealed cylindrical jar together with ball bearings as milling 
media. The jar and the milling media are referred to as the mill-
ing assembly and are typically made of steel or an inert inorganic 
substance, such as tungsten carbide (WC), agate, ruby or alumina 
(Al2O3). The jar is then shaken along a radial path. Most commer-
cially available mixer mills allow the electronic control of milling 
time and frequency, which is typically between 20 and 40 Hz.  
A number of physical parameters can be varied to affect the 
optimization of mechanochemical reactions. These parameters 
include the number of milling balls and their diameter, weight 
and density, as well as the shape and volume of the milling jar and 
its material. Mechanochemical reactions are often characterized 
by the ratio of the weight of milling balls to the weight of the 
milled sample. It is a common misconception that using more 
milling balls will increase the force of impact during milling. In 
a shaker mill, increasing the number of milling balls or their size 
can substantially reduce the available path for their movement 
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and acceleration, thus leading to a weaker impact and insufficient 
mixing. An effective strategy for increasing the impact force when 
using a shaker mill is to first reduce the number of milling balls 
and then increase their weight, either by using larger balls or by 
using balls made of a material with a higher density (for example, 
replacing stainless steel with tungsten carbide).

The success of mechanosynthesis in diverse16 areas of inor-
ganic, organic, metal-organic and supramolecular chemistry17 
can be attributed to the emergence of modified mechanochemical 
strategies: liquid-assisted grinding18 (LAG, also known as solvent-
drop grinding, solvent-assisted grinding19 or kneading20), ion- 
and liquid-assisted grinding (ILAG)21, grinding-annealing22 and 
film grinding23. Both LAG and ILAG provide a general means to 
modify the chemical environment of the mechanochemical reac-
tion, akin to how solvent choice can affect the outcome and yield 
of a reaction in solution. In LAG, mechanochemical reactivity is 
induced or accelerated by near-stoichiometric or substoichiomet-
ric amounts of a liquid. LAG is particularly effective for synthe-
sizing and screening for multicomponent crystals (cocrystals), 
including pharmaceutical cocrystals, coordination polymers and 
porous metal-organic frameworks24. The added liquid also allows 
active control over the structure and composition of the mech-
anochemical product, by templating open networks or selectively 
forming polymorphs25. ILAG is a modification of LAG, in which 
reactivity is further enhanced by small, substoichiometric (typi-
cally 5–10 mol%) amounts of an ionic salt in addition to the liq-
uid, hence the term ion- and liquid-assisted18. Recent applications 
of ILAG include the green synthesis of and screening for porous 
metal-organic frameworks and the synthesis of metallopharma-
ceuticals. Grinding-annealing and film grinding have so far been 
used only in specific instances for the synthesis of coordination 
polymers and mechanically interlocked structures, respectively, 
by combining mechanochemical treatment with a thermal or a 
solution-based step.

It is not yet fully understood how mechanochemical reactions 
are accelerated and directed by the grinding liquid in LAG or 
ILAG. It is clear that the grinding liquid can increase the rate 
of mechanochemical transformations19. However, a systematic 
study of LAG cocrystallization revealed little or no relation-
ship between the solubility of reactants in the grinding liquid 
and reaction acceleration. In several cases, structure-directing 
effects of the grinding liquid were explained through specific  
hydrogen- or halogen-bonding interactions. Recently, the param-
eter η was introduced26 as a means to characterize the conditions 
of LAG reactions and to make them comparable to other syn-
thetic methodologies, such as neat (dry) grinding, reactions in 
slurries or reactions in solution. η is simply defined as the ratio 
of the volume of the added liquid and the mass of the solid reac-
tants. Empirically, in LAG reactions, η is 1 µl mg−1 or less, reac-
tions in sonicated slurries have η values between 1 µl mg−1 and  
12 µl mg−1, and cases in which η  > 12 µl mg−1 correspond to 
conventional solution chemistry. The mechanochemical con-
ditions used in our laboratory for the synthesis of cocrystals, 
organic molecules or coordination compounds normally corre-
spond to η  =  0.25 µl mg−1 (i.e., 50 µl of the grinding liquid and 
200 mg of the solid reactant mixture). The reaction is normally 
contained in a jar of 14 ml in volume and is milled using one 
or two stainless steel balls of 7 mm in diameter. As each ball  
weighs ~1.4 g, this corresponds to ball-to-sample weight ratios 

of 7 and 14, respectively. Such conditions are sufficient for the 
laboratory synthesis of most cocrystals, including pharmaceu-
tically relevant materials. η is often higher for the synthesis 
of porous metal-organic frameworks, as the milling liquid is 
depleted during the reaction while being incorporated as a guest 
into the pores of the product.

Methodology for real-time, in situ reaction monitoring
Our methodology for monitoring mechanochemical reac-
tions14 uses high-energy (hard) X-ray radiation of energy 
(~90 keV), available at the European Synchrotron Radiation 
Facility (ESRF) beamline station ID15B. Such radiation readily 
 penetrates through the walls of a milling container regardless of 
its composition. We applied this methodology to jars made of 
poly(methyl)methacrylate (PMMA, also known as Plexiglas or 
Perspex), aluminum or steel. As a result of its high penetrating 
power, the radiation will undergo diffraction on the crystalline 
components of the sample as it is being milled. The diffracted 
radiation is of sufficiently high intensity to again penetrate out 
of the milling container, and it is subsequently detected using an 
area X-ray detector in the form of a 2D diffractogram. Integration 
of the obtained 2D patterns yields a conventional X-ray powder 
diffraction pattern in which the intensity of scattered radiation 
is plotted against the diffraction angle (2θ). The X-ray diffrac-
tion pattern represents a characteristic ‘signature’ of a crystalline 
substance, determined by its crystal structure. Noncrystalline 
(amorphous) materials do not show sharp X-ray diffraction 
peaks. Idealized powder X-ray diffraction (PXRD) patterns are 
readily simulated for each substance on the basis of the knowl-
edge of its crystal structure, thereby providing a means to identify 

a

c d

b

Figure 1 | Milling equipment for in situ X-ray diffraction measurements.  
(a) An assembled 14-ml PMMA jar, as used in the experiments described 
herein. (b) Milling jars of different sizes made from steel, aluminum or PMMA. 
The milling media are steel balls. (c,d) Side view (c) and front view (d) of the 
modified Retsch MM200 mill with the milling stations lifted above the mill to 
allow for the X-ray beam to pass above the mill and through the jars.
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 substances and qualitatively identify reaction products and reac-
tants. Quantitative X-ray diffraction analysis of the reaction 
course is performed by Pawley and Rietveld refinement, whereas 
peak-broadening analysis allows the monitoring of changes in 
average particle size in the sample14.

The experiment described herein is representative of this new 
experimental methodology, and it is conducted in a PMMA mill-
ing jar of 14 ml in volume that was designed and manufactured 
in-house (Fig. 1). The detailed plans for the manufacture of the 
jars, which are equally applicable to aluminum or stainless steel 
as jar materials, are provided in the Supplementary Manual.  
We conducted milling using an in-house–modified ball mill 
MM200 manufactured by Retsch. The modifications to the com-
mercially available mill are described here in detail and were 
done to allow the X-ray beam to access the sample: the milling jar  
stations were vertically lifted using aluminum bars, which were 
balanced using empirically determined weights.

Design of milling jars and the milling apparatus
The milling experiments are performed in milling jars made from 
commercially available PMMA, steel or aluminum rods accord-
ing to the design in the Supplementary Manual. Although the 
external shape of the jar is cylindrical, the internal cavity must be 
rounded (egg-shaped) to facilitate ball movement and to avoid the 
accumulation of materials in corners. The internal jar volume in 
our experiments is 14 ml3 and grinding jar walls are 3 mm thick. 
This jar size is suitable for reactions involving 200–600 mg of solid 
material. For smaller amounts of material, smaller milling jars can 
be engineered with a 10-mm internal diameter and a 3-mm wall 
thickness. Although we have done mechanistic LAG and ILAG 
studies14 in PMMA jars, stainless steel or aluminum jars have been 
used for neat (dry) milling reactions (Fig. 1a,b), in which plastic 
jars get easily damaged by harsh impact and abrasion.

Scope of mechanochemical synthesis and in situ reaction studies
The procedure described herein is pertinent to the recently devel-
oped mechanochemical synthesis14,27 of microporous zeolitic 
imidazolate frameworks (ZIFs)28 by milling together zinc oxide 
and imidazole ligands under ILAG conditions. In particular, the 
detailed procedure addresses the formation of the popular ZIF-8 
framework (also known as MAF-4 and commercially available as 
Basolite Z1200) from ZnO and 2-methylimidazole in the pres-
ence of N,N-dimethylformamide (DMF) as the grinding liquid 

and ammonium nitrate (NH4NO3) as the reaction-enhancing 
salt additive (Fig. 2a,b). However, the scope of mechanochemical 
milling synthesis is much wider and, in principle, the methodol-
ogy described here should also be adaptable to the study of all 
such known reactions, ranging from the formation and trans-
formations of pharmaceutical materials (cocrystals, salts, poly-
morphs and solvates)1,18 and organic molecules6,9 to inorganic 
materials—for example, perovskites29 or complex metal hydrides 
for hydrogen storage30. The methodology, as described, requires 
access to a source of high-energy X-rays, such as provided at the 
ESRF synchrotron beamline ID15B, and it should perform even 
better for samples with heavier atoms. For materials comprising 
only light atoms (e.g., C, H, N, B, O), such as organic molecules 
(pharmaceuticals, self-assembled cages31 and covalent-organic 
frameworks32), the procedure could be optimized by slightly 
increasing the radiation wavelength, as well as by increasing the 
amount of sample in the reaction jar. The procedure described 
here is optimized for 14-ml reaction vessels and produces  
~0.5 g (2 mmol) of the ZIF-8 metal-organic framework. By using 
the same experimental conditions, reaction at a lower scale gives 
poorer results in terms of measurement quality.
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Figure 2 | Chemical reaction and experimental setup. (a) Scheme of the 
general reaction for the mechanochemical (LAG or ILAG) conversion of zinc 
oxide into porous ZIFs. (b) Fragment of the crystal structure for the ZIF-8 
product based on zinc(II) and 2-methylimidazolate ions. (c) Positioning  
of the modified Retsch MM200 mill on a motorized stand, movable in the  
x-, y- (horizontal) and z-directions (vertical).

MaterIals
REAGENTS

Zinc oxide (Sigma-Aldrich, CAS no. 1314-13-2) ! cautIon Zinc oxide 
causes mild skin irritation and eye irritation; it is very toxic to aquatic life. 
Use personal protective equipment while handling zinc oxide. Avoid dust 
formation and inhalation. Avoid breathing vapor, mist or gas of zinc oxide. 
Ensure adequate ventilation and evacuate personnel to safe areas while 
working with it. 2-methylimidazole (Sigma-Aldrich, CAS no. 693-98-1)  
! cautIon 2-methylimidazole is corrosive. Use personal protective  
equipment while working with it. Avoid dust formation and inhalation. 
Avoid breathing vapor, mist or gas of 2-methylimidazole. Ensure adequate 
ventilation and evacuate personnel to safe areas while working with it  
N,N-dimethylformamide (Sigma-Aldrich, CAS no. 68-12-2).  

•
! cautIon N,N-dimethylformamide is a combustible liquid, a teratogen 
and a moderate eye irritant. Wear respiratory protection while working 
with it. Avoid breathing vapor, mist or gas. Ensure adequate ventilation and 
evacuate personnel to safe areas while working with it. Remove all sources 
of ignition while handling it and avoid accumulation of its vapors to  
explosive concentrations.
Ammonium nitrate (Sigma-Aldrich, CAS no. 6484-52-2) ! cautIon  
Ammonium nitrate is an oxidizer. Use personal protective equipment while 
working with the reagent. Avoid breathing vapor, mist or gas of ammonium 
nitrate. Avoid dust formation and inhalation. Ensure adequate ventilation 
while working with ammonium nitrate. Ensure adequate ventilation and 
evacuate personnel to safe areas while working with it.

•
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EQUIPMENT
Retsch MM200 mill and metal parts for its modification  
(Supplementary Manual)
Loctite 241 glue
In-house–manufactured PMMA milling jars, 14-ml volume  
(Supplementary Manual)
Motorized stand for mounting the mill, movable in horizontal (x, y) and 
vertical (z) directions, which can be controlled remotely
Automatic pipette, volume 10–200 µl
Access to the ID15B ESRF synchrotron beamline
PC-compatible computer
Conventional software for treatment (e.g., Fit2d, Powder3D) and analysis 
of X-ray powder diffraction data (e.g., TOPAS, GSAS II, Fullprof) and its 
simulation from existing crystal structure information (e.g., Mercury). 
Powder3D is a free software for noncommercial use that can be downloaded 
from http://www2.fkf.mpg.de/xray/html/powder3D.html

EQUIPMENT SETUP
Data integration Data integration can be performed using Fit2d  
software, which is free for academic use and is available from the web at: 

•

•
•

•

•
•
•
•

http://www.esrf.eu/computing/scientific/FIT2D. Frames can be processed 
one at a time, but as there are hundreds of data frames in each milling  
experiment, automatic integration is advised. Fit2d is available as an  
executable file for Windows, Linux or MacOS operating systems.
Powder diffraction pattern simulation The immediate analysis of  
integrated X-ray powder diffraction patterns is readily achieved by  
comparing them with diffraction patterns simulated for expected  
mechanochemical products or substances that could structurally resemble 
them. The crystallographic data required for such calculation are normally 
found deposited within the general databases of crystallographic data, such 
as the Crystal Structure Database (CSD, http://www.ccdc.cam.ac.uk/pages/
Home.aspx), the Inorganic Crystal Structure Database (ICSD, http://www.
fiz-karlsruhe.com/icsd.html) or the Crystallography Open Database (COD, 
http://www.crystallography.net/index.php), from which it can be extracted  
in the standard .cif (Crystallographic Information File) format. Calculation 
of simulated diffraction patterns is readily conducted using the freeware  
program Mercury, designed and distributed by the Cambridge Crystallographic 
Data Centre. Mercury is available for PC, Linux and MacOS installations.

proceDure
stage I: modification of the mill
 crItIcal The Retsch MM200 mill must first be modified in several simple steps through which the conventional sample 
jar holders, referred to as milling stations, are replaced with in-house manufactured extensions. These modifications result in 
the milling jar being lifted vertically above the instrument, allowing the incident X-ray beam to access the jar while the mill 
is kept in an upright position.

1| Remove the countersunk screws of the grinding jar fastening the jar holder (milling station) to the rocker arm. The screws  
are glued with Loctite 241 glue and will need to be warmed with a blowtorch for 40–50 s before trying to undo them.

2| Assemble the extension as per the technical drawing provided in the supplementary Manual. Fix the extension with a 
new screw to the rocker arm. Screw the jar holder to the elevated base according to the instructions in the technical  
drawing. The screw may need to have Loctite glue applied again. The completed mill will look as in Figure 1c,d.

3| Ensure that the assembled extension is properly balanced and that left and right milling stations are aligned in mutually 
parallel manner. The best way of making sure that the mill is balanced is by operating it for a few minutes at a frequency of 
30 Hz. If it is properly balanced, the mill will not vibrate strongly, move or be noticeably noisier than its normal setup.

4| Place the modified Retsch MM200 mill on a movable stand whose positioning is controlled by a set of horizontal (x and y) 
and vertical (z) motors that are controlled from the control hutch. The mill is fastened to the stand with strong tape (Fig. 2c).

stage II: sample preparation and jar mounting
 crItIcal Liquids with a high vapor pressure or low boiling point (e.g., acetone, chloroform, dichloromethane) should, if 
possible, be avoided, as these are likely to evaporate during the sample preparation. As the reaction kinetics are influenced 
by the amount of liquid present, any evaporation could lead to inaccuracies. This problem can be ameliorated by preparing 
the sample quickly. The grinding liquid should ideally be chosen to be compatible with the grinding jars. We found that,  
over time, crazing developed in the PMMA jars owing to the small amount of DMF and N,N-diethylformamide in the reaction. 
The crazing reduced the transparency of the jars, although they were otherwise still functional. If noticeable cracks appear 
in the walls of the jar, it should be discarded. When you use 14-ml jars, the total amount of starting materials should be 
between 200 and 600 mg. Using less than 200 mg of starting materials leads to rapid erosion of steel-grinding media and 
appearance of steel particles in the product, recognized by gray coloration. The use of more than 600 mg of reactant  
materials hinders the movement of milling media, leading to slow reactions and inhomogeneous products.

5| Weigh out 2 mmol (162.8 mg) of zinc oxide (ZnO) and 4 mmol (328.4 mg for 2-methylimidazole) of the imidazole  
ligand directly into one half of the empty milling jar. Weighing precision for each component should be within 0.1 mg.  
These amounts of materials will provide a reaction mixture weight close to 0.5 g.
 crItIcal step The reagents should not be ground before weighing, so as to avoid mechanical activation and potential 
onset of reaction before milling has taken place.

http://www2.fkf.mpg.de/xray/html/powder3D.html
http://www.esrf.eu/computing/scientific/FIT2D
http://www.ccdc.cam.ac.uk/pages/Home.aspx
http://www.ccdc.cam.ac.uk/pages/Home.aspx
http://www.fiz-karlsruhe.com/icsd.html
http://www.fiz-karlsruhe.com/icsd.html
http://www.crystallography.net/index.php
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6| To conduct an ILAG reaction, a substoichiometric 
amount of a salt additive is added to the reaction, typi-
cally in 5–10 mol% with respect to ZnO. For this particular 
experiment, weigh 0.1 mmol (8.0 mg) of ammonium nitrate 
(NH4NO3) in the half of the jar with other solid reactants.

7| For LAG and ILAG experiments, a carefully measured 
quantity of DMF as the grinding liquid is added using an 
automatic pipette. It is important to contain the liquid in 
a single drop or a small puddle and to avoid spreading the 
liquid on the jar walls. Typical volumes of grinding liquid are 
between 25 and 150 µl. For this particular reaction, measure 100 µl of DMF into the second empty half of the milling jar.

8| Introduce the milling media, typically one or two stainless steel balls of 7 mm diameter (1.4 g each), to the half of the 
milling jar containing the liquid. After adding the balls, do not shake or swirl the jar, as the movement of the ball and the 
spreading of the liquid across the container must be minimized to avoid accidental mixing with the solid reagents once  
the jar is snapped together.

9| Orient this half of the milling jar, containing the grinding ball and the grinding liquid, horizontally with a slight  
downward tilt.

10| Orient the other half of the milling jar, containing the solid sample, horizontally and slightly tilted such that the open 
side is facing upward (Fig. 3a). This should be performed very carefully and the jar must be tilted only slightly, with no or 
minimal movement of the solid sample (Fig. 3a).

11| Snap the two halves of the jar together (Fig. 3b). If done properly, the grinding ball with the grinding liquid will remain 
in one side of the jar and the solid reactants in the other. This has been performed so far with liquids of different viscosities 
and vapor pressures, such as ethanol, DMF, N,N-diethylformamide or water.
 crItIcal step Liquids of high vapor pressures and low boiling points should, if possible, be avoided. Steps 7–11 should 
be done as quickly as possible to prevent evaporative loss of the liquid or the extensive absorption of air moisture that could 
affect the results.

12| Place the milling jar horizontally into the milling station of the modified MM200 ball mill and clamp the jar in place. 
Positioning of the jar must be performed very carefully, again to prevent the movement of the wet ball toward the solid  
reaction mixture (Fig. 3c).
 crItIcal step While clamping the jar, a piece of horizontal thin cork placed on the milling station can be used to help 
keep the jar horizontal.

13| Verify the frequency and time settings on the MM200 mill. Typically, reactions are conducted at 30 Hz and the time is 
set to 90 min. However, the reaction might be stopped after less than 90 min via remote control.
 crItIcal step We have used an area detector to be able to collect the whole powder diffraction pattern at once.  
This gives the best time resolution, but at the expense of diffraction pattern resolution, as there are no X-ray optics on the 
diffracted beam path. Given the very short wavelength used (0.14271 Å), the expected powder pattern will shrink and the 
relevant data will be at a small 2θ (note that the 110 reflection of iron at ~45.5° using CuKα radiation appears here at ~4°). 
Move the detector as far as possible from the sample in order to allow the Debye-Scherrer rings to be separated as much as 
possible. Calibrate the detector distance, tilt and radiation wavelength using a standard sample.

14| Verify the proper positioning of the mill and the jar with respect to the incident beam using a theodolite (Fig. 3d).  
In our experiment, we positioned the jar so as to allow the incident beam to pass ~3 mm above the bottom internal wall. 

a d

b

c

Figure 3 | Experiment preparation. (a) Proper handling of the two halves of 
the PMMA milling jar before snapping them together. (b) The milling jar after 
snapping the two halves together. The left side contains the milling liquid 
and milling balls. The right side contains the reactants (white powder).  
(c) Horizontal positioning of the PMMA milling jar on the milling station.  
(d) The positioning of the milling jar with respect to the X-ray beam is 
verified using a theodolite.
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Under such conditions, X-ray diffraction can take place both 
on the sample attached to milling jar walls, as well as the 
sample on the surface of the moving ball. The correct  
positioning of the mill was achieved by the movement of  
the x-, y- and z-motors of the stand.

15| By following the safety procedure delineated by the synchrotron facility, perform the safety check and experimental 
hutch search. After the experiment hutch is evacuated, the hutch door is interlocked and the X-ray shutter is opened.

stage III: remote control of the experiment
16| Initiate the milling remotely. To enable the observation of the mechanochemical process as soon as the milling is  
initiated, the reaction mill must be controlled remotely from the control hutch. In our case, this was achieved by  
constructing a primitive ‘robotic finger’ that was electronically controlled and could perform the horizontal and vertical 
movements required for pressing the mill ‘start’ and ‘stop’ buttons (Fig. 4).
? trouBlesHootInG

stage IV: milling jar cleaning
17| After completing the milling experiment, scrape the product out of the milling jar using a plastic spatula. If necessary, a 
metal spatula can be used, although this risks damage to the softer PMMA milling jars.
 crItIcal step Typically, if the reaction product is a porous metal-organic framework, the sample after milling is dry,  
because the grinding liquid is absorbed within the microporous material. The formation of a dry product in LAG and ILAG 
reactions is a good indication of the formation of a porous solid. If, however, the milling product in a LAG or ILAG process 
adopts an unexpected gray or black color, it is indicative of too much liquid, which facilitates ball-wall or ball-ball (if using 
multiple milling balls) impacts, leading to increased friction and formation of metal shavings. This typically means a smaller 
amount of milling liquid should be used.
? trouBlesHootInG
 pause poInt The product after removal from the milling jar is the microporous framework ZIF-8 with DMF and small amount 
of nitrate and ammonium ions included in the pores. The material can be stored in a closed vial for extensive periods of time 
(weeks or months), although the presence of included DMF and nitrate salt may lead to slow degradation to the nonporous 
analog of ZIF-8. A recent report suggests that such instability might be generally valid for ZIFs33. To avoid such structural 
collapse upon prolonged storage, the sample can be treated using a general method for washing of porous metal-organic 
frameworks, which consists of washing with methanol (or any other convenient low-boiling solvent), filtration under suction 
and drying in vacuo. The sample after treatment should be stable indefinitely upon storage in a closed vial.

18| Once the product has been removed, wipe the inside of the jar with a paper towel, and then wipe with deionized water 
and a paper towel. Clean PMMA milling jars by soaking for a few minutes in a solution of 30% (vol/vol) concentrated  
hydrochloric acid in deionized water to remove any adhered materials. The jars are then removed from the acid solution and 
rinsed with deionized water. The acid solution can be reused several times.

19| Metal (e.g., steel) jars would be rapidly corroded by the acid solution; clean these jars by washing with soap and water, 
then with ethanol, and finally by rinsing with deionized water. The metal jars can be scrubbed using wire wool instead of a 
paper towel, if necessary. The metal milling balls can be cleaned in the same way.
 crItIcal step Cleaning the jars can be accelerated by placing them in a beaker filled with the cleaning solution (acid or 
soap), which is then sonicated for 5–15 min in a sonic bath. This, however, can accelerate the aging and reduce the life span 
of the PMMA milling jars.

20| To dry the jars and balls, leave them in an oven at 60 °C. Once they are dry, remove the jars and balls and allow them to 
cool to room temperature (20–25 °C) before using them in a milling reaction.
 crItIcal step Before drying at 60 °C, the jars can be rinsed with methanol. Although such treatment enables faster 
drying of the PMMA milling jars, it may also accelerate their aging and reduce their life span.

Motor

X-ray source ‘Finger’

Figure 4 | Outside control of mill operation. View of the improvised robotic 
‘finger’ for remote switching on and switching off of the modified Retsch 
MM200 mill. The control is achieved by having the finger press the ‘START’ or 
‘STOP’ buttons on the horizontal mill control board.
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stage V: data processing
21| Run data integration on a single frame before proceeding to the automatic integration of the entire data set.  
Start the Fit2d software and accept the conditions of use.

22| Provide the information about the dimensions of the detector. Here the detector size is 2,640 × 1,920 pixels. Change the 
detector size if needed by clicking on the yellow button on the right, and then deleting the old values and typing in the new 
values. Click on the yellow O.K. button in the upper left.

23| Choose POWDER DIFFRACTION (2D).

24| To determine the beam center, first select one data frame from the data set.

25| The selected data frame should be displayed. Choose BEAM CENTER followed by CIRCLE COORDINATES.

26| Choose a few points (three at least, but preferably five or six) from which Fit2d will calculate the beam center.  
Decide on the well-defined Debye-Scherrer ring. The ring belonging to iron could be a good choice. Avoid high-angle  
rings belonging to the sample or to ZnO because they may be split into two rings. Use the TWO CLICK option in the lower 
right of the Fit2d window in order to first select a part of the data frame, which is zoomed-in and displayed in the  
lower left of the Fit2d window. In this zoomed-in part, select the data point in the middle of the chosen Debye-Scherrer 
ring. Repeat the procedure for the same ring until a few points are selected, then click on the big yellow button  
(click here to finish).
? trouBlesHootInG

27| Click on INTEGRATE. In the following window, the values for the beam center should now be updated. Insert other  
required values, which are for our experiments given in Figure 5. Values for the detector distance and tilt are normally  
available from the detector calibration.

28| Click O.K.

29| Click O.K.

30| The integrated pattern is now displayed. Save it by clicking on the OUTPUT button and choosing the CHIPLOT data format.

31| In order to automatically integrate the whole set, return to the main menu by clicking on CANCEL and EXIT.

32| In the main menu, choose the FILE SERIES button.

33| Click on INTEGRATE.

34| In the upper part of the Fit2d window, you are prompted to select the first data frame of the series. The file browser is 
active, so navigate to the directory where the raw data frames are saved and select the first file. Fit2d can decipher your file 
series, provided that they are given in a meaningful sequence. For instance, it is enough that any file name ends with the 
sequence number of the frame: ‘SOMENAME0001.edf’, ‘SOMENAME0002.edf’. Here we have used the ‘.edf’ data format (for ESRF 
data format), which simply lists pixel intensities point by point.

35| After selecting the first file, Fit2d displays the data frame and asks if this is the correct file. Click on YES.

36| In the upper part of the Fit2d window, you are then prompted to select the last data frame that is to be processed.  
File increment is 1 meaning that we will use each data frame. Click O.K.

37| In the next window, if you do not have specific measurements for the detector, click O.K.

38| There is no need to integrate the whole frame, so you should zoom in on part of the data frame. Afterward, only the 
zoomed-in part will be integrated. Including the part with the 110 iron reflection is sufficient. If needed, mask certain parts 
of the frame, such as the beam stop. Click EXIT when you are finished.
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39| In the next window, check the given values and change them if needed. Correct values should have been saved from  
the integration of a single data frame. The coordinates of the beam center should have been saved from the optimization  
in Step 31. Click O.K.

40| Click O.K.

41| At the next screen, you are asked to save integrated patterns. Click YES.

42| Choose CHIPLOT as the data format.

43| Change the file extension to ‘xy’, and click O.K. The file series will be integrated and the files saved to the same directory 
with the raw data.
? trouBlesHootInG

stage VI: data reduction and plotting
 crItIcal The powder diffraction patterns are not normalized. Normalization can be performed using the Powder3D  
program.

44| Start Powder3D by starting the file Powder3D.sav within the IDL virtual machine.

Figure 5 | Data processing. Screenshots of Fit2d after opening the data file and at the end of integration data input, with the values for the experimental 
setup as previously determined from a calibration procedure involving a standard sample.
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45| Go to File → Import and choose xy because the powder diffraction patterns have been saved with the extension ‘xy’  
(Step 43).

46| Navigate to the directory containing the files and select them all. Click Open.

47| Click O.K.

48| A progress bar is displayed during importing. Click O.K. The first pattern is displayed.

49| Go to Plot → 2D-film. The whole data set is plotted and a small window appears with plot controls. Portions of the plot 
can be expanded by clicking and dragging the mouse cursor over the desired region. Close the small window. All the patterns 
are now selected.

50| Go to Window → Tools. The small tool window is opened. Choose the second icon from the top to crop the patterns.  
Two dashed red lines represent the crop region. Drag the red lines to choose the crop region to start at ~0.4° and end before 
the iron diffraction peak at ~4°. Press Enter and then O.K. at the prompt.

51| Go to Edit → Normalize patterns. A new window appears.

52| Find a region where none of the patterns have any diffraction peaks. Zoom on it by left-clicking and dragging.  
In order to select a region, which will be used for normalization, drag with the right mouse button pressed. Click O.K.

53| Go to Display → Normalized.

54| Go to Plot → 2D-film. The plot should now be smoother.

55| To subtract the background from each pattern, close the small window for 2D plotting controls. Go to Edit → Background. 
In the window that opened, remove the tick from ‘Reduce anchor number’. Set the curvature to 0.00 and increase the  
percentage of anchor points to 25%. Click on Generate → Single.

56| The background is now estimated and shown with the red curve. Increase the percentage of anchor points to 35%,  
and click on Generate → Single.

57| Adjust the values for curvature and percentage of anchor points to obtain the best estimate. Take care to ensure  
that the background estimate does not take away peak intensity. Once the parameters for background are set, select  
Generate → All.

58| Monitor the progress for each pattern to make sure no outliers occur.
! cautIon This procedure will probably create some negative intensity points and probably will not be perfect for each pattern.

59| Once finished, click Display → Background corrected.

60| To have all the data in one file, click File → Export → Data → Array and save the file.

61| Plot the data array file, for example, using the Powder 3D Mathematica program, in order to create 2D, time-resolved 
diffractograms (Fig. 6a). Alternatively, you can analyze individual raw X-ray powder diffractograms (without subtracted  
background) using standard Pawley and Rietveld fitting to identify or quantify the crystalline components of the reaction 
mixture (Fig. 6b).
? trouBlesHootInG

stage VII: simulation of X-ray powder diffraction patterns
62| In the Mercury program, go to File → Open and browse to the .cif file containing the crystallographic data for 
the substance whose diffraction pattern should be simulated. The screen displays the 3D image of a fragment of the 
crystal structure.
? trouBlesHootInG
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63| Click the Powder button in the bottom center of the screen. Within a second, the simulated diffraction pattern appears 
(Fig. 7a). However, the positioning of X-ray diffraction features depends on the choice of the X-ray radiation wavelength, 
which is by default given as 1.54056 Å (CuKα radiation).

64| Click the Customise button in the top right section of the window displaying the simulated X-ray diffraction pattern.  
A new window appears, with a selection of various parameters distributed over three tabs: Pattern, Tick marks and  
Preferred orientation.

65| In the Pattern tab, which opens by default, click in the window labeled Wavelength 1 (Angstroms). Replace  
the default number 1.54056 with the wavelength used for in situ experiments. In our case, the wavelength is  
0.14271 Å (Fig. 7b).

66| Click O.K. The window disappears, revealing a new simulated diffraction pattern that can be compared with  
experimentally obtained data in a suitable program. For this, the simulated pattern needs to be saved for  
later upload.

67| In the top section of the window displaying the simu-
lated diffraction pattern, click Save. A dialogue window 
appears in which you determine where to save the simulated 
diffraction pattern. Notably, the pattern can be saved in 
a number of formats conventionally used in X-ray powder 
diffraction data analysis. The two formats commonly used in 
our group are the plain text format (.xye) and the propri-
etary Bruker format (.raw).
 crItIcal step For comparisons and overlays of simulated 
and experimental patterns, our group normally uses X’Pert 
HighScore from Panalytical, although a number of other  
programs can be used, including any spreadsheet program. 
For Pawley and Rietveld refinements, the information given 
in the .cif files can be directly used to calculate powder  
diffraction patterns to describe the measured patterns. In 
our work14, we have used the program TOPAS (Bruker-AXS or 
TOPAS-Academic, Coelho Software) for that purpose.
? trouBlesHootInG

a

b

Figure 7 | Qualitative identification of products using Mercury.  
(a,b) Screenshots of simulating the PXRD pattern for a known crystal  
structure (a) and of changing the wavelength for the simulated diffraction 
pattern (b).
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Figure 6 | Data presentation and quantitative 
analysis. (a) Example of a time-resolved PXRD 
pattern (diffractogram) for the LAG synthesis of 
ZIF-8. The simulated powder diffraction pattern 
of the product is displayed on top. (b) Combined 
Pawley and Rietveld refinement for reaction a  
after 9 min and 40 s. The blue tick marks 
designate calculated positions of reflections 
for the product. Blue, observed pattern; red, 
calculated pattern/background; gray, difference 
pattern. The contribution of ZnO (blue) is 
inserted below the experimental pattern. 
Selected reflections of the product, as well  
as steel from the milling balls, are highlighted.
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? trouBlesHootInG
Troubleshooting advice can be found in table 1.

antIcIpateD results
The described methodology allows direct insight into the course of a mechanochemical reaction. After identifying  
participating crystalline solids, the time-resolved diffractograms are plotted as in Figure 6 to show the evolution of the 
composition of the reaction mixture as it is being milled. The reaction mixture is analyzed by fitting diffraction patterns to 
obtain quantitative information on its composition. The influence of the reaction environment on the reaction mechanism 
and kinetics, including the type and amount of added liquid and the choice of catalytic salt additive, can be directly  
estimated and reaction conditions can thus be optimized.

taBle 1 | Troubleshooting table.

step problem possible reason solution

16, 26, 43 The diffraction pattern shows only background 
(and possibly X-ray reflections coming from the 
steel balls in the milling assembly); this occurs 
when the sample is not exposed to the beam 

Poor positioning of the mill and  
milling station

The mill and the milling assembly 
should be carefully positioned using 
a theodolite

The sample has become attached to 
the sides of the jar

When too much liquid is used in LAG 
and ILAG, the sample will have a 
tendency to pile up on the opposite 
sides of the jar. Switch to a smaller η 
(less liquid)

The sample has become amorphous No need for troubleshooting:  
amorphization can be a part of  
the reaction mechanism18

17 The sample appears gray or black Too much liquid in LAG or ILAG 
enhances the abrasion of the steel 
assembly, resulting in the appearance 
of metal particles

Switch to a smaller η

26, 43 Initial diffraction patterns for the synthesis 
of a porous framework contain reflections of 
reactants or products, but these eventually 
disappear, leaving behind only background 
and X-ray reflections coming from the milling 
assembly

The porous framework initially formed 
has collapsed, liberating liquid 
included as a guest. This increases η 
and can lead to the sample becoming 
attached to opposite sides of the jar 
and remaining outside of the beam 

No need for troubleshooting: this 
indicates a reaction mechanism in 
which the initial porous structure 
collapses

61, 62, 67 The reaction product or intermediate  
diffraction pattern cannot be matched  
to that simulated for any known structures

This material has not been previously 
crystallographically characterized

Attempt structure determination, 
either by PXRD or, if the sample can 
also be grown in as single crystals, 
by single-crystal X-ray diffraction

Note: Supplementary information is available in the online version of the paper.
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21. Friščić, T. et al. Ion- and liquid-assisted grinding: improved mechanochemical 
synthesis of metal-organic frameworks reveals salt inclusion and anion 
templating. Angew. Chem. Int. Ed. 49, 712–715 (2010).

22. Kuroda, R., Yoshida, J., Nakamura, A. & Nishikiori, S.-i. Annealing assisted 
mechanochemical syntheses of transition-metal coordination compounds 
and co-crystal formation. CrystEngComm 11, 427–432 (2009).

23. Hsueh, S.-Y., Cheng, K.-W., Lai, C.-C. & Chiu, S.-H. Efficient solvent-free 
syntheses of [2]- and [4]Rotaxanes. Angew. Chem. Int. Ed. 47, 4436–4439 
(2007).
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